samedi 29 novembre 2014

Excel : compter les doublons

bt-excel

Voici une question posée sur le forum Answers.

Dans la plage de cellule B3:C16 combien de fois il y a, sur une même ligne, les valeurs "ABC" en colonne "A" et "115" en colonne "B".

Excel-2013-nb-répétitions

Pour répondre à cette question voici la proposition faite par MichD :

  • Avec une version antérieure à Excel 2007, utilisez la formule :
    =SOMMEPROD((B3:B16=”ABC”)*(C3:C16=115))
      
  • À partir d'Excel 2007, Utilisez aussi cette formule :
    =NB.SI.ENS(B3:B16;”ABC”;C3:C16;115)

Le résultat de cette formule peut être exploitée de différentes manières :

  • Si le résultat=2 comme dans notre exemple, cela signifie que les valeurs “ABC” dans la colonne “A” et 115 dans la colonne “B” sont répétées deux fois sur une même ligne. En d’autres termes nous avons un doublon.
     
  • Si le résultat=1 cela signifie que les valeurs n’existent que sur une seul ligne sont uniques.
     
  • Enfin si le résultat=0 cela signifie qu’aucune des lignes ne contient à la fois la valeur “ABC” en colonne “A” et 115 en colonne “B”.
      
Mots clés Technorati : ,,,